Windows-админы должны обновить PowerShell, чтобы устранить баг обхода WDAC

Microsoft просит системных администраторов обратить внимание не две уязвимости PowerShell 7, которые необходимо пропачтить как можно скорее. В случае успешной эксплуатации они позволят злоумышленникам обойти защитный слой Windows Defender Application Control (WDAC) и получить доступ к паролям в виде простого текста.

Как известно, бреши затрагивают версии PowerShell 7 и PowerShell 7.1, поэтому админы могут смело устанавливать релизы PowerShell 7.0.8 и PowerShell 7.1.5, которые разработчики выпустили в сентябре и октябре соответственно.

Функция WDAC предназначена для защиты устройств от потенциально вредоносного софта, её основная задача — убедиться, что пользователь запускает только доверенные программы. Своего рода «белый» список позволяет исключить работу нежелательных или злонамеренных приложений.

Если контроль WDAC активирован в системе, PowerShell автоматически переключается в режим ограничения языка программирования, который подразумевает, что потенциально опасные API Windows не будут задействоваться.

Однако неприятный баг под идентификатором CVE-2020-0951 позволяет злоумышленникам обойти «белый» список WDAC и запустить блокируемые команды PowerShell. Сама Microsoft описывает эту проблему так:

«Для эксплуатации уязвимости атакующему потребуется доступ администратора к компьютеру, на котором запущен PowerShell. В этом случае злоумышленник может подключиться к PowerShell-сессии и отправить команды для выполнения произвольного кода».

Другая брешь под идентификатором CVE-2021-41355 приводит к раскрытию информации в .NET Core. В случае эксплуатации этот баг может открыть атакующим доступ к учётным данным, хранящимся в виде простого текста.

Anti-Malware

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *