Выпуск http-сервера Lighttpd 1.4.60

Состоялся релиз легковесного http-сервера lighttpd 1.4.60. В новой версии представлено 437 изменений, в основном связанных с устранением ошибок и оптимизациями.

Основные новшества:

  • Добавлена поддержка заголовка Range (RFC-7233) для всех непотоковых ответов (ранее Range поддерживался только при отдаче статических файлов).
  • Проведена оптимизация реализации протокола HTTP/2, в которой снижено потребление памяти и ускорена обработка интенсивно отправляемых начальных запросов.
  • Проведена работа по снижению потребления памяти.
  • Повышена производительность lua в модуле mod_magnet.
  • Повышена производительность модуля mod_dirlisting и добавлена опция для настройки кэширования.
  • В mod_dirlisting, mod_ssi и mod_webdav добавлены ограничения для предотвращения большого потребления памяти при экстремальных нагрузках.
  • На стороне бэкенда добавлены отдельные ограничения на время выполнения вызовов connect(), write() и read().
  • Обеспечен перезапуск если зафиксировано большое смещение времени системных часов (приводило к проблемам с TLS 1.3 на встраиваемых системах).
  • Таймаут на подсоединение к бэкенду по умолчанию выставлен в 8 секунд (можно изменить в настройках).

Дополнительно опубликовано предупреждение об изменении поведения и некоторых настроек по умолчанию. Изменения планируется применить в начале 2022 года.

  • Таймаут по умолчанию для операций graceful restart/shutdown планируется уменьшить с бесконечности до 5 секунд. Таймаут можно настроить при помощи опции «server.graceful-shutdown-timeout».
  • Будет объявлена устаревшей сборка с libev и FAM, вместо которых будут задействованы родные для операционных систем интерфейсы для обработки цикла событий и отслеживания изменений в ФС (epoll() и inotify() в Linux, kqueue() в *BSD).
  • Будут переведены в разряд устаревших и удалены в будущих выпусках модули mod_compress (нужно использовать mod_deflate), mod_geoip (нужно использовать mod_maxminddb), mod_authn_mysql (нужно использовать mod_authn_dbi), mod_mysql_vhost (нужно использовать mod_vhostdb_dbi), mod_cml (нужно использовать mod_magnet) и mod_flv_streaming.

https://www.opennet.ru/opennews/

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *